Thunderbird Issue re Mail on Server

POP Peeper: Tech support, suggestions, discussion, etc.
Post Reply
RJGnyc
Posts: 3
Joined: Fri Jul 03, 2020 12:04 pm

Thunderbird Issue re Mail on Server

Post by RJGnyc »

This is an issue that started recently. I use Win10 Pro and Thunderbird for most e-mail, and use POP Peeper to weed out mail before I open Thunderbird. Until a few weeks ago, my process was to delete garbage/redundant incoming mail within POP Peeper, and then refresh the incoming mail list; when I then opened the Thunderbird client it would download only the undeleted mail. However, now I find that all of the mail is still downloaded, as if it has not been deleted from the server.
POP Peeper has been very useful because I have a very old (legacy) account with my web service provider, so I cannot rely on their webmail connection -- it is slow and buggy (and often freezes until timeout). But now I am uncertain whether POP Peeper is really deleting the mail from the server.
Can anyone help with this?
Thanks!
-rg
User avatar
Jeff
Admin / Developer
Posts: 8512
Joined: Sat Sep 08, 2001 9:46 pm

Re: Thunderbird Issue re Mail on Server

Post by Jeff »

What protocol are you using and are POP Peeper and TB both using the same protocol (ie. are they both using POP3 or are they both using IMAP)? In POP Peeper, you can edit the account and refer to the "server type" value.

After you do a check mail in PP to delete the email, do another email check and see if the messages return or not -- let us know the results.

When you say that TB is receiving the messages, are the deleted messages appearing in the Inbox or another folder?

Are you fully exiting TB when you're not using it?
RJGnyc
Posts: 3
Joined: Fri Jul 03, 2020 12:04 pm

Re: Thunderbird Issue re Mail on Server

Post by RJGnyc »

Thank you for your quick response!

Both servers are set as POP3 (not IMAP).

After I delete mail in PP, I do an e-mail check and they are no longer shown.

I then close PP completely, wait around 30 seconds, open TB -- only to find that the "deleted" mail appears in the inbox of TB.

Regarding completely closing TB and PP: I hate leaving stray bits of code running in the background, so I take care to completely exit programs. (For example, I now have to do a full Quit to kill Zoom after every meeting.) I can confirm that TB and PP are not running via the Task Manager.
User avatar
Jeff
Admin / Developer
Posts: 8512
Joined: Sat Sep 08, 2001 9:46 pm

Re: Thunderbird Issue re Mail on Server

Post by Jeff »

You may want to check if there are any relevant settings in your account. Some POP3 servers may have an option that prevents delete, or some servers will automatically delete messages when they're retrieved.

But it doesn't seem logical that TB would pick up messages that PP doesn't display. So, as an experiment, after you delete the messages in PP and then exit PP -- restart PP and check the mail again (ie. before starting TB).

Also, if you email me (support at esumsoft dot com), I can provide instructions to create a log file and we can see if there's anything unusual happening.
RJGnyc
Posts: 3
Joined: Fri Jul 03, 2020 12:04 pm

Re: Thunderbird Issue re Mail on Server

Post by RJGnyc »

Via PP I deleted a number of Wolferman and other catalogue type e-mails (somehow they evade the e-mail rules I set up specifically for them on the provider's webmail site). I Checked Mail and they did not show up. I closed and re-opened PP and they were still gone. Opened Thunderbird and they downloaded.
Because of long delays in trying to log in to the provider's webmail, signing on later to check the status isn't always possible. However, the last time I was able to check it, I noticed that a number of items that were flagged for deletion in PP were still on the server -- but not all of them.
I will send an e-mail so that you can send instructions for a log file.
Thanks again!
Post Reply