AT&T Yahoo Mail Retrieval Error

POP Peeper: Tech support, suggestions, discussion, etc.
Post Reply
User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

AT&T Yahoo Mail Retrieval Error

Post by Godiva » Mon Jul 09, 2018 3:07 pm

Within about the past hour my AT&T Yahoo account stop logging on via POP Peeper. The error message is:
Login Error: Check your Login Name and Password.
My PP setting for this account was changed to a Yahoo server type over a month ago, and has worked fine until today (no other changes have been made at my end). Logging on to the website with the exact same credentials works fine. Also, retrieving using POP3 with my normal client (Eudora) works fine. FYI, I did a PP version check, and everything within PP (v4.5.1.0) is reported as up-to-date.

So hopefully this is a temporary glitch that will rectify itself later today, otherwise it's a change in Yahoo's sign in that needs to be addressed within PP.

I'm posting about the problem now (even though it's only been an issue for less than an hour), in case others are experiencing similar issues. I won't be back until late tonight, if it has fixed itself by then, I'll update this thread.

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Jeff » Mon Jul 09, 2018 6:11 pm

Thanks for the heads-up.

I can confirm that this error popped up around the time you mentioned because I had performed a webmail test several hours earlier and it had passed, but got an error after reading your report.

WebMail update has been released -- WebMail v4.5.4. Go to Help / About and press "Check version" to auto-update.

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Godiva » Mon Jul 09, 2018 8:55 pm

Working again, danke sehr!

FYI, your Webmail.dll version history on the website has the wrong date (shows May 01, just like v4.5.3).

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Jeff » Thu Jul 12, 2018 11:11 pm

Missed your edit the first time, but it's updated now.

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Godiva » Wed Oct 10, 2018 11:25 am

Jeff, I'm starting to get a longer lag than normal when retrieving messages in this account. This may be simply because of the number of unarchived messages have been increasing (the count is currently about 1000 messages), but the last time this delay happened, it was followed by a complete failure to retrieve (which you then fixed). I'm letting you know, in case this latest lag is something that can be tested, and hopefully fixed before it fails.

NOTE: My PPPro is v4.5.2. Webmail version is 4.5.4.0. I see that there's a Webmail v4.5.5.0, but the About screen says "Webmail update does not apply to existing accounts", so I haven't yet tried to update the Webmail dll. All other modules are up to date.

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Jeff » Wed Oct 10, 2018 3:01 pm

I just tested a few accounts and I don't see what I would call significant lag, but I also don't have a good feel for how long it *should* take -- when I run the test, it's just an automated process that I start (it checks every supported web service, some with multiple accounts) and then I go about my business until the report pops up.

I'll keep my eye on it, but you will probably be aware of any issues before I am, so let me know if a problem arises.

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Godiva » Wed Oct 10, 2018 3:17 pm

Jeff wrote:
Wed Oct 10, 2018 3:01 pm
I'll keep my eye on it, but you will probably be aware of any issues before I am, so let me know if a problem arises.
Will do.

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Godiva » Sun Oct 28, 2018 1:06 pm

FYI, I just retrieved over 1000 emails in this account into my local client (which then deleted them from the AT&T Yahoo server), and the check time for this account dropped drastically. So (based on a sample size of 1), the large number of undeleted messages seems to have been the main reason for the lag this time.

It also looks like deleting the server messages reduced the launch time of the program as well (make sense, but when the delay increments slowly over several months, you don't really notice it).

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Jeff » Mon Oct 29, 2018 4:01 pm

This is especially true for WebMail (POP3/IMAP are affected, but in a different way and it's nowhere near the impact, so this discussion is specifically for webmail), but the more messages you have, the more time and resources it will take. As a general rule, it's important to keep WebMail accounts to a minimum number of messages.

POP Peeper does provide a setting to mitigate this:
main menu: Tools / Optins
page: Message Retrieval
enable: "WebMail: retrieve only the first page"

Unfortunately, some webmail services no longer allow you to change the number of messages per page like they used to, so you *may* be stuck with a limited number of messages that may not work well for you. For example, I think Yahoo defaults to 25 messages per page, but at one time, you could change it to 200 (for a while, you could still change it in the "classic" interface, but I don't know if that's still the case).

Actually, it's possible that I had, at some point, made it possible so that you could set the number of pages (ie. instead of forcing just one page, you could tell it 4 pages, which would at least allow you to see the 100 most recent messages). If this is something you'd be interested in, let me know and I'll try to find it.

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Godiva » Mon Oct 29, 2018 4:10 pm

Jeff wrote:
Mon Oct 29, 2018 4:01 pm
Actually, it's possible that I had, at some point, made it possible so that you could set the number of pages (ie. instead of forcing just one page, you could tell it 4 pages, which would at least allow you to see the 100 most recent messages). If this is something you'd be interested in, let me know and I'll try to find it.
Yes, please. Even better (eventually, not immediately) have page retrieval limits specific to each account.

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Jeff » Mon Oct 29, 2018 6:16 pm

Global setting (which already exists): you'll need to:
1) Exit POP Peeper (perhaps get the ini location first under main menu: Tools / Options / Storage)
2) Edit the ini file
3) In the [POP PEEPER] section, set:
WMRetrievePages = #
--> note1: this value may already exist, make sure you edit the value if it already exists; if it doesn't, then add the line
--> note2: 0 is the default which means "get all pages". If you had set the option so that PP only retrieves 1 page, then this value would be 1. You can change it to any value you want.
4) Save and restart PP


Per-account setting -- this has been added and will be in v5. This will NOT be available in the GUI, but you can add it now and it will keep in v4 (but again, it won't be supported until v5):
1) Exit POP Peeper
2) Edit the ini file
3) In the appropriate [Act_Name] section (where "Name" is the name of your account), add the following line:
WMRetrievePages = #
4) Save and restart PP
Note1: this is similar to the global option, the only difference is the section where you assign 'WMRetrievePages'. For the per-account setting, you can add the setting to each account that you want to change.
Note2: Per-account setting has precedence over the global setting (ie. you can set global to 5 and one account to 3)

Additional note: CASE-SENSITIVE (e.g. don't use wmretrievepages)
Reiteration: make sure you exit PP before editing the ini file or any manual changes you make will be overwritten when PP saves the ini.


I think that covers everything...

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Godiva » Tue Oct 30, 2018 1:23 am

Très cool - merci! I haven't tried it out yet, but I'll post here once I do.

Is the number of messages per page dependent on the server? For example, I think my AT&T Yahoo account displays 50 messages per page on their website, and I know my Gmail account displays 100. Or does Pop Peeper define a page as 25 messages regardless of the account?

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Jeff » Tue Oct 30, 2018 3:28 pm

POP Peeper gets as many messages per page as defined on the server; in some cases, you may be able to change that in your account settings online (not in PP). Some servers have some rather unusual settings; Hotmail, for example, will often cache additional messages on the page, so you may get an odd number like 29 messages.

Also, keep in mind that when messages "fall off the page", PP forgets everything about them. If the messages come back onto the page (ie. you delete newer messages), PP will consider them as "new" if they are unread on the server. So there are 2 ways to deal with this:
1) Make sure you mark all older messages as read
2) Create a rule in PP that marks older messages as "read" or "ignored"

* If you look in AntiJunk, you may notice that PP is missing the capability to process the "date" field; it's actually a hidden option because it's not a very useful filter for most cases. But you can type "+Date" in the appropriate field and if you have "Show help" enabled, you'll see the necessary information. So, for example, you could specify
+Date > 7 (days)
and apply an action to "ignore" -- end result is that any messages older than 7 days won't trigger the new message notifications.

mdv921
Posts: 28
Joined: Mon Jul 28, 2008 8:48 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by mdv921 » Mon Nov 05, 2018 8:41 pm

Yahoo Mail has stopped working again in the last few hours. I get the following error. I can sign into my Yahoo accounts through the website with no problem.

Error UNAVAILABLE LOGIN Server Error - Please Try Again Later

mdv921
Posts: 28
Joined: Mon Jul 28, 2008 8:48 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by mdv921 » Mon Nov 05, 2018 8:46 pm

Yahoo is now working again. Go figure.

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Jeff » Mon Nov 05, 2018 8:53 pm

Yes, I had been getting an OAuth-related error on my Yahoo account for maybe an hour. Just as soon as it was getting annoying enough to stop what I was doing and investigate Yahoo, it started working again :)

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Godiva » Thu Jan 24, 2019 4:12 pm

It's happening again - can't retrieve any emails (in fact it scared me when I saw ZERO messages in the PP "Total" column for this account, but I checked the website, and there are messages there. Here's the dump:

==========================================================================================
--- Version ---
OS: Windows 7 (x64)
POP Peeper: 4.5.2.0
Webmail: 4.5.6.0
SSL: 1.0.2.16
IMAP: 4.5.2.0
RSS: 4.5.0.0
SendMail: 4.5.2.0
Notification Skin: 4.3.0.0
Notification Voice: 4.5.0.0 (disabled)
Profile Picture: 4.5.0.0
AntiJunk: 4.5.0.0
Spell Checker: 4.5.0.0
Web of Trust: 4.5.0.0

--- Web Test ---
Result: 200
Error:
Time: 14:57:12 - 14:57:13 (1 s) (-0600)
Data: Thu, 24 Jan 2019 12:57:13 -0800

--- Error ---
AT&T [3: Yahoo] ['pop.att.yahoo.com' (993) SSL: 1] [Smtp: 'smtp.att.yahoo.com' (587) SSL: 2] [consec: 3]
- Error: Try again later. (-11)
==========================================================================================

UPDATE: POP3 Retrieval works fine, but trying to retrieve with the "Yahoo" server type fails.

BTW, when I choose Yahoo server type (or IMAP), there is no OAuth2 button available for that account (not sure if it ever was, but I saw that you mentioned in a previous post for your Yahoo account). There is such a button for my Gmail account (when server type is IMAP).

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Jeff » Thu Jan 24, 2019 4:23 pm

WebMail update v4.5.6 was released a short while ago to address the Yahoo issue:
https://www.esumsoft.com/products/pop-p ... s/#WebMail

BTW, when I choose Yahoo server type, there is no OAUTH button available (not sure if it ever was, but I saw that you mentioned in a previous post for your Yahoo account).
OAuth is only for IMAP.

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Godiva » Thu Jan 24, 2019 4:37 pm

Jeff,

From my dump above: Webmail: 4.5.6.0 - so I have the latest Webmail showing (and it shows as 4.5.6.0 is both "Current" and "Latest" columns on my PP About window).


Also, even if I choose IMAP for my Yahoo account, no OAuth2 button appears. This isn't critical to the current issue, but since you wrote on Nov 5 (the last post before I posted today): "Yes, I had been getting an OAuth-related error on my Yahoo account for maybe an hour.", I was a bit confused.

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: AT&T Yahoo Mail Retrieval Error

Post by Jeff » Thu Jan 24, 2019 7:40 pm

Sorry, I missed that you had the latest already and now another :oops: because I really messed up v4.5.6. I had forgotten that Yahoo had 3 different interfaces (basic, classic, full) instead of just 2 and that really threw off my testing.

So, WebMail v4.5.7 is now available and it shouldn't have a problem with basic or full. I don't think it should be a problem with classic either, but once I started messing with my account, I couldn't get back to classic to test (it only switches between basic and full). I opened a couple other accounts and they weren't using classic either. The other issue is that I'm not sure if Yahoo plans on discontinuing basic or not. I don't get a popup telling me that it will be discontinued like I was getting with classic, but the basic interface seems to be based on classic so I wonder. If they do discontinue basic, then I expect PP's Yahoo/webmail support to have issues on Feb01. I suspect that basic *will* continue to function and they've just decided that there's no reason to have both classic and full.

Also, even if I choose IMAP for my Yahoo account, no OAuth2 button appears.
It's probably the way that your account is setup since it's an at&t and not native yahoo. The only requirements (in this case) to make the OAuth button accessible is that it's an IMAP account and that the incoming server is set to imap.mail.yahoo.com. If you have to manually type the server, then it won't instantly appear -- you need to either save and re-open the account, or re-select "IMAP" for the server type.

Post Reply