Not All CC Names Showing In CC Field

POP Peeper: Tech support, suggestions, discussion, etc.
Post Reply
User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Not All CC Names Showing In CC Field

Post by Godiva » Fri Feb 08, 2019 1:05 pm

I just sent an email via PP that included two names in the CC field. In both the BCC copy I received, as well as the reply (which the sender used a "reply all") and only one of the names showed up in the CC field. This has happened three times today (two emails sent, one reply, PP shows only one of the two names in the CC field for all three emails). I first thought that I had accidentally BCC'd the 2nd person, but when I looked at the webmail (AT&T Yahoo) account, both names showed up in the CC field via my browser.

I don't remember this happening before, and I know on at least some accounts (primarily Gmail), I see more than one name showing up in PP's CC field. My most frequently used Gmail account is used for work, so having multiple CCs is common. However, my AT&T Yahoo account is for personal use, so having even one CC isn't that common, and more than one is quite rare. Also PP only has emails for this Yahoo account from the past 10 days, so even if I had sent other emails with more than one CC, they are no longer in PP (already retrieved to my local client). Because of this, it's hard for me to know if my Yahoo account has always behaved this way, or if it's a new problem.

Any ideas?

FYI, server type is Yahoo, all modules are up-to-date (including WebMail at 4.5.7.0).

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: Not All CC Names Showing In CC Field

Post by Jeff » Fri Feb 08, 2019 1:36 pm

What protocol are you using to send the mail -- smtp or webmail?

Also -- without using the original data -- can you include the exact format of what you used in the CC field? ie. what did you use for the separator and did the 2 recipients have names or just email address or mix?

For example:
"name 1" <example1@yahoo.com>; example2@yahoo.com

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: Not All CC Names Showing In CC Field

Post by Godiva » Fri Feb 08, 2019 2:25 pm

Sending Protocol - SMTP (smtp.att.yahoo.com) STARTTLS, Port 587

For the real messages I used PP's "address" feature to populate the CC field: Click on a name on the left side, then click on the CC button. Looking at it afterwards, a semi-colon separates each entry. Both CC entries included a name and email address, with quotations around each name and angle brackets around each email address.

So they looked like this: "name 1" <example1@yahoo.com>; "name 2" <example2@yahoo.com>
This is how they look in the Yahoo website as well.

Since I wrote my original post I sent some test messages by manually typing in multiple addresses into the CC field. In this case, I used only the email address separated by commas. So it looked like this: t1@yahoo.com, t2@yahoo.com, t3@yahoo.com (this is also how is looked on the Yahoo website).

But again, only t1@yahoo.com shows up in PPs CC field (in the copy of the email that is BCC'd to myself).

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: Not All CC Names Showing In CC Field

Post by Jeff » Sun Feb 10, 2019 2:44 pm

I just performed several different tests using various formats and separators and all recipients received the messages successfully.

Yahoo had a global outage on Friday when I was originally going to test this. Have you tested it again since then -- perhaps it was down for maintenance and they fixed the problem?

Since you've successfully tested another SMTP server (presumably using very similar data), it seems likely that the problem is on Yahoo's end, but if you still have the problme, email me and we can take a look at the logs and see what's happening.

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: Not All CC Names Showing In CC Field

Post by Godiva » Sun Feb 10, 2019 3:26 pm

Jeff wrote:
Sun Feb 10, 2019 2:44 pm
1) I just performed several different tests using various formats and separators and all recipients received the messages successfully.

2) Yahoo had a global outage on Friday when I was originally going to test this. Have you tested it again since then -- perhaps it was down for maintenance and they fixed the problem?

3) Since you've successfully tested another SMTP server (presumably using very similar data), it seems likely that the problem is on Yahoo's end, but if you still have the problme, email me and we can take a look at the logs and see what's happening.
1) I'm not saying that all the recipients didn't receive the messages (in fact, I verified that they DID), I'm saying that the CC field in my PP copy of the sent message only showed the first name CC'd (so that I either had to call the user in the 2nd CC to make sure they got it, or check the web version of my Yahoo account (which showed all CCs)).

2) I just tried another test, CC'd it to 2 addresses. But again, only the first address shows up in the CC field of the PP copy of the sent message.

3) Can do, but I want to be sure you understand what the problem actually is (and then let me know you still need the log info). Since the way I'm describing it, it seems more likely to be a problem with PopPeeper not showing all the CC's than any problem with Yahoo.

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: Not All CC Names Showing In CC Field

Post by Jeff » Sun Feb 10, 2019 3:48 pm

Ah, ok, sorry for the misunderstanding. So a couple more follow-ups:

1) Does this problem occur in POP Peeper's message list (ie. the actual CC that you received) or in Sent Mail Viewer (or both)?

2) Are you CC'ing yourself or BCC'ing yourself? If the former, are you the first address in the CC or the second?

Now that I understand the problem better (maybe), I'm still not able to see it for myself -- both CC's appear in both PP and SMV. And the CC is correct for the other recipients' emails, too.

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: Not All CC Names Showing In CC Field

Post by Godiva » Sun Feb 10, 2019 4:32 pm

1) The problem occurs in the message list (the BCC that I received). However, it displays properly in the Sent Mail Viewer (until your post, I totally forgot about that viewer!).

2) As mentioned above, I am automatically BCC'ing myself, but CC'ing others.

Since I can see the correct CC list in the Sent Mail Viewer (and don't have to go to Yahoo's web display), the problem is now reduced to a minor annoyance. But I'm willing to test it further in case you want to fix it for the purpose of making sure everything's working properly.

A heads-up: I will be doing some major hardware upgrades on my system this coming week, so I'm not going to be able to do any testing until next week at the earliest. I can do one more test today (maybe two more), but that will be it for awhile.

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: Not All CC Names Showing In CC Field

Post by Godiva » Sun Feb 10, 2019 5:03 pm

UPDATE: I just reviewed my opening post which reads (in part): "In both the BCC copy I received, as well as the reply (which the sender used a "reply all") and only one of the names showed up in the CC field."

Because viewing the reply in PP doesn't show more than one CC name (but they all do show up in Yahoo's website email), and because I can't use the Sent Mail Viewer to see all the CC's in the reply, this has increased the problem back from a minor annoyance to an annoyance (if PP can't properly tell me who got CC'd, then I'm not getting all the proper info about a received email from within PP).

User avatar
Jeff
Admin / Developer
Posts: 8436
Joined: Sat Sep 08, 2001 9:46 pm

Re: Not All CC Names Showing In CC Field

Post by Jeff » Sun Feb 10, 2019 5:17 pm

Let's do this:

1) Log the send mail --
a) Compose a message that you know will cause a problem (don't send it yet)
b) Be sure to note exactly what you have for the "to" "cc" and "bcc" fields (so that you can explicitly tell me what they were)
c) use "Send Later" (make sure there's plenty of time before the next check mail so you can do the next step)
d) While holding down F8, right-click on the account that has the outgoing message
e) At the bottom of the menu, select "Quick Log"
f) If you're asked if you want to disconnect (you may not be, depending on the account), you can select "no"
g) After the log completes, Windows Explorer should open with the log file

2) Get your copy of the email
a) "Check Mail" the account that you BCC'd yourself on the above message
b) View the message and verify that it's missing values
c) From this menu, select File / Save message as
d) Save the message

3) Send the following information to me (email preferred, or PM; definitely not via public forum)
- The log file saved in #1 above
- The message source saved in #2 above
- The exact 'to' 'cc' and 'bcc' fields as you recorded in #1b above

User avatar
Godiva
Posts: 187
Joined: Sat Mar 06, 2010 5:22 pm

Re: Not All CC Names Showing In CC Field

Post by Godiva » Sun Feb 10, 2019 7:44 pm

PM sent.

Post Reply