POP3 delete mail not working W10

POP Peeper: Tech support, suggestions, discussion, etc.
Post Reply
jetsfan
Posts: 18
Joined: Tue Dec 06, 2011 3:38 pm

POP3 delete mail not working W10

Post by jetsfan »

Hi,

For the last few days PopPeeper 4.5.3.0 looks like it is deleting marked messages but when screen is refreshed using the check mail function the 'deleted' messages reappear.
Deleting messages from the server using outlook or webmail works ok.

Deleting mail from the same provider works on a different W10 PC for a different email account. Version is also 4.5.3.0.

Tried stopping/restarting PP and restarting the PC.

Think this has happened some years ago but cant remember the fix.

Any suggestions please?
User avatar
lakrsrool
Moderator
Posts: 1617
Joined: Sun Jul 17, 2011 2:36 am

Re: POP3 delete mail not working W10

Post by lakrsrool »

Hi jetsfan,
1) Are these accounts using "POP3"? (based on your topic description referencing "POP3" this is what I'm assuming)
2) What Email Service has this problem (Gmail, Yahoo, Outlook.com etc)?
3) Are you using "Advanced Options"? (you know by going from the main PP menu to "Tools" > "Options... > "General" window to see if there is a check-mark for "Advanced Options". If it is checked (enabled) then edit one of the problem accounts and select "Advanced" in the left-pane to see if "Remove messages not on server" is checked (it should be for what you want).
4) Are the account settings on your other PC that works exactly the same? (check to see if you can find a difference between the PC with the problem and the PC that works).
5) When you say it "looks like it is deleting" - what do you mean by that? When you delete a message -- Do you see the blue trash-can in the Misc Status column (usually the first column in the In-box)?
6) After deleting a message in PP are you checking that same account on-line using your browser? And if you are doing this are you certain that this same message has been removed from the accounts In-box when you check the account on-line using your browser?
7) Are you getting any PP errors when you delete messages for these problem accounts (you will have a yellow exclamation in the lower-right corner of the main PP interface if so)? If you are getting errors please post the errors.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
jetsfan
Posts: 18
Joined: Tue Dec 06, 2011 3:38 pm

Re: POP3 delete mail not working W10

Post by jetsfan »

Hi lakrsrool. Thanks for posting.

Darndest thin,g the delete function started working properly around midday but I'll answer your questions as best as I can for the record.


1) Are these accounts using "POP3"? (based on your topic description referencing "POP3" this is what I'm assuming)

Yes Pop3

2) What Email Service has this problem (Gmail, Yahoo, Outlook.com etc)?

Email service is provided by ISP, Bell Canada.

3) Are you using "Advanced Options"? (you know by going from the main PP menu to "Tools" > "Options... > "General" window to see if there is a check-mark for "Advanced Options". If it is checked (enabled) then edit one of the problem accounts and select "Advanced" in the left-pane to see if "Remove messages not on server" is checked (it should be for what you want).

Yes remove msgs not on server is checked

4) Are the account settings on your other PC that works exactly the same? (check to see if you can find a difference between the PC with the problem and the PC that works).

Can't see a difference

5) When you say it "looks like it is deleting" - what do you mean by that? When you delete a message -- Do you see the blue trash-can in the Misc Status column (usually the first column in the In-box)?

I saw the trash can and saw the message disappear when check mail was selected only to see it reappear when check mail was clicked a second time. Looking at the server through webmail the message was still showing in the inbox.

6) After deleting a message in PP are you checking that same account on-line using your browser? And if you are doing this are you certain that this same message has been removed from the accounts In-box when you check the account on-line using your browser?

Message was not being removed by pop peeper

7) Are you getting any PP errors when you delete messages for these problem accounts (you will have a yellow exclamation in the lower-right corner of the main PP interface if so)? If you are getting errors please post the errors.[/u]


No errors were showing when the messages were not being deleted from the server.


Like I said its working now and nothing was changed with the PP settings. Quite the mystery.

Thanks for the checklist. If it happens at a later date I'll post again. It's done it before some years ago but can't remember if there was a fix. At that time the ISP was probably using Microsoft but they parted company. Not sure where their email service is from these days but they do not run their own email servers. Guess we can close this thread now??
'
User avatar
lakrsrool
Moderator
Posts: 1617
Joined: Sun Jul 17, 2011 2:36 am

Re: POP3 delete mail not working W10

Post by lakrsrool »

What you said here: "Looking at the server through webmail the message was still showing in the inbox." -- suggests to me (because the messages remained in your accounts In-box) that your Email Service provider's Servers were likely having some temporary (random) issues that was preventing the removal of the messages off of their Servers. The temporary issue appears to have eventually cleared up as expected.

Thanks for providing your feedback. Image
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
User avatar
Jeff
Admin / Developer
Posts: 8513
Joined: Sat Sep 08, 2001 9:46 pm

Re: POP3 delete mail not working W10

Post by Jeff »

And just as a possible explanation as to why one of your other accounts did work -- are you checking that other account with IMAP? It's possible that the problem only occurred with a specific protocol; and, for that reason (among others), you may want to consider using IMAP instead of POP3 because most clients use IMAP these days and so ISP's are less likely to put resources into POP3 (and there are fewer people to report potential issues). Imap provides many advantages over POP3 regardless, and there's generally little to no reason to use POP3 when IMAP is available.
jetsfan
Posts: 18
Joined: Tue Dec 06, 2011 3:38 pm

Re: POP3 delete mail not working W10

Post by jetsfan »

Thanks guys. Both accounts are POP, I've never been a big fan of IMAP so will stick with it as long as it's supported.

Likely a bug in the server since it started working again with no changes in Poppeeper's configuration.
Post Reply